Установка более старой версии пакета emacs [дубликат]


На этот вопрос уже есть ответ здесь:

Я недавно обновил Emacs Cider через MELPA, и, похоже, на моей машине есть ошибка. Мне не нужны сборки bleeding edge, и я счастлив вернуться к более старой сборке, пока они не исправят проблему . Однако я не уверен, как это сделать. чтобы установить старую версию пакета, существующего в списке пакетов.

Я ищу либо:

  1. Установите старую версию Cider через собственный менеджер пакетов Emacs
  2. Установите старую версию Cider из исходного кода

Edit: this was closed as a duplicate of Is it possible to downgrade packages installed with ELPA?, однако у этого не было ответа, поэтому я переспросил вопрос.

1   10  

1 ответ:

Вы можете сделать следующее

1) Удалите cider из собственного менеджера пакетов emacs. (Сделайте M-x list-packages пометку пакета сидра с помощью d, а затем нажмите x, чтобы удалить пакет)

2) загрузите последнюю версию, которая работала для вас, со страницы релизов сидра

3) следуйте инструкциям по установке, приведенным здесь

Надеюсь, это поможет!