Ubuntu работает `pip install " дает ошибку "следующие необходимые пакеты не могут быть построены: * freetype'


при выполнении pip install -r requirements.txt, Я получаю следующую ошибку во время этапа, где он устанавливает matplotlib:

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [not found. pip may install it below.]
              dateutil: yes [dateutil was not found. It is required for date
                        axis support. pip/easy_install may attempt to
                        install it after matplotlib.]
               tornado: yes [tornado was not found. It is required for the
                        WebAgg backend. pip/easy_install may attempt to
                        install it after matplotlib.]
             pyparsing: yes [pyparsing was not found. It is required for
                        mathtext support. pip/easy_install may attempt to
                        install it after matplotlib.]
                 pycxx: yes [Couldn't import.  Using local copy.]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: no  [pkg-config information for 'freetype2' could
                        not be found.]

...

The following required packages can not be built:

                    * freetype

не стоит pip install -r requirements.txt также установить freetype? Как должен быть установлен freetype в Ubuntu 12.04, чтобы он работал с matplotlib?

9   139  

9 ответов:

нет. pip не будет устанавливать зависимости системного уровня. Это значит pip не будет устанавливать RPM (s) (системы на основе Redhat) или DEB (s) (системы на базе Debian).

для установки системных зависимостей вам нужно будет использовать один из следующих методов в зависимости от вашей системы.

Ubuntu / Debian:

apt-get install libfreetype6-dev

для поиска пакетов на базе Ubuntu / Debian системы:

apt-cache search <string>

например:

apt-cache search freetype | grep dev

Redhat / CentOS / Fedora:

yum -y install freetype-devel

для поиска пакетов в системах на базе Redhat/CentOS/Fedora:

yum search <string>

например:

yum search freetype | grep devel

Mac OS X: (через доморощенного)

brew install freetype

для поиска пакетов в системах на базе Mac OS X:

brew search <string>

например:

brew search freetype

мне пришлось установить libxft-dev для того, чтобы включить matplotlib на ubuntu server 14.04.

sudo apt-get install libfreetype6-dev libxft-dev

и тогда я мог бы использовать

sudo easy_install matplotlib

обходной путь, чтобы сделать sudo apt-get install pkg-config что я нашел в этом выпуске github.

ни один из существующих ответов не работал для меня, чтобы обновить matplotlib на Ubuntu. Это в конечном итоге работает для меня:

$ sudo apt-get install build-dep python-matplotlib
$ pip install matplotlib --upgrade

эта команда загрузит все зависимости.

для python 2.x

sudo apt-get install python-matplotlib

для python 3.x

sudo apt-get install python3-matplotlib

после установки, вы можете попробовать

(sudo) pip install matplotlib

на Ubuntu, он работал после того как я установлен blt-dev пакета.

$sudo apt-get install blt-dev
$pip install matplotlib

Я использую мяту ни один из этих ответов не работал для меня, мне нужно было:

sudo apt-get install build-essential g++

У меня была такая же проблема с Python 3.6 в Windows, но затем я переключился на Python 3.5.2, и все работает нормально.

эта команда sudo apt-get install libfreetype6-dev не удалось для меня на ubuntu 16.04,
The following packages have unmet dependencies: libfreetype6-dev : Depends: libfreetype6 (= 2.6.1-0.1ubuntu2) but 2.6.1-0.1ubuntu2.3 is to be installed

так я скачал установлена только с источник, в руководство

$ tar -xvjf freetype-x.y.tar.bz2  # extract the downloaded version file
$ cd freetype-x.y/ 
$ ./configure
$ make
$ sudo make install 

переключился на virtualenv и pip install matplotlib и все работает.