Узел обновление определенного пакета


Я хочу обновить свой браузер-синхронизация без обновления всех моих пакетов узлов. Как я могу этого достичь? В моей текущей версии Browser-sync нет графического интерфейса Browser-sync: (

├─┬ [email protected]
│ ├── [email protected]
1   52  

1 ответ:

большую часть времени вы можете просто обновление модуль, как это сделать не нарушая изменений (соблюдая semver, указанный в вашем пакете.json) (

npm update browser-sync
  • использовать npm outdated чтобы увидеть, какие модули имеют более новые версии
  • использовать npm update (без имени пакета) для обновления всех модулей
  • включить --save-dev если вы хотите сохранить новую версию номера к вашему пакету.формат JSON. (Примечание: начиная с npm v5. 0 это будет сделано автоматически для вас).

в вашем случае, похоже, вы хотите следующую основную версию (v2.x.x), который, вероятно, будет иметь критические изменения, и вам нужно будет обновить приложение, чтобы учесть эти изменения. Вы можете установить/сохранить последнюю версию 2.x.x делаем:

npm install [email protected] --save-dev

...или последний 2.1.x делаем:

npm install [email protected] --save-dev

...или последний и самый большой делаем:

npm install [email protected] --save-dev

Примечание: последний ничем не отличается от этого:

npm uninstall browser-sync --save-dev
npm install browser-sync --save-dev

The --save-dev часть очень важна. Это позволит удалить его, удалить значение из вашего пакета.JSON, а затем переустановите последнюю версию и сохраните новое значение в своем пакете.формат JSON. Если вы опустите --save-dev часть, она ничем не отличается от выполнения команды обновления выше.