Bootstrap: 'TypeError undefined is not a function' /'has no method' tab " при использовании bootstrap-tabs


Я строю небольшой сайт на данный момент и хотел бы использовать некоторые из загрузочных частей из Initialzr, в частности вкладки. В настоящее время я попытался использовать пример кода, предоставленный проектом Bootstrap (http://twitter.github.com/bootstrap/javascript.html#tabs) и несколько настроек, но получить "неопределенный не является функцией" при загрузке.

файлы JS загружаются в правильном порядке (jQuery, libs/bootstrap/*, мой скрипт.js файл / скрипт смешанный в html), стандартный jQuery команды (скрыть и т. д.) Все работают нормально, поэтому он не связан с опцией noConflict ().

Что еще мне нужно проверить?

5   51  

5 ответов:

Это также может быть вызвано, если вы включите bootstrap.js до jquery.js.

другие могут иметь ту же проблему, что и я.

включить jQuery до bootstrap.

Мне действительно удалось выяснить, что я делал неправильно (и это была моя вина).

Я привык использовать Pre-jQuery Rails, поэтому, когда я включил файлы JS Bootstrap, я не думал, что в том числе версия jQuery в комплекте с ними вызовет какие-либо проблемы, однако когда я удалил этот файл JS, все начало работать отлично.

урок выучен, трижды проверьте, какие файлы JS загружаются, посмотрите, есть ли какие-либо конфликты.

убедитесь, что вы используя новейший jquery, и проблема решена

Я встретил эту проблему с помощью этого кода:

<script src="/scripts/plugins/jquery/jquery-1.6.2.min.js"> </script>
<script src="/scripts/plugins/bootstrap/js/bootstrap.js"></script>

после изменения его на это:

<script src="/scripts/plugins/jquery/jquery-1.7.2.min.js"> </script>
<script src="/scripts/plugins/bootstrap/js/bootstrap.js"></script>

Он работает

вероятно, это использование события" on", которое Bootstrap использует много и было вставлено в jQuery 1.7 http://api.jquery.com/on/

мы можем попробовать, используя последнюю библиотеку jQuery. У меня такая же проблема. Я использовал jQuery-1.4.2.мин до и получение ошибки. После этого я использовал версию 1.9.1 и он работает. Спасибо