Ugrade tmux от 1.8 до 1.9 на Ubuntu 14.04


Я просто добавлял Плагины tmux к моему .tmux.conf файл, чтобы узнать, что один из плагинов (tmux-copycat я думаю) требует tmux 1.9. Когда я запускаю tmux, я получаю сообщение " Ошибка: версия Tmux не поддерживается. Пожалуйста, установите tmux версии 1.9 или выше!".

Итак, каков наилучший способ обновить tmux 1.8 до 1.9 на Ubuntu 14.04?

3   57  

3 ответа:

обновление: из-за новой версии tmux и изменений в репозитории пакетов Этот ответ обновляется, чтобы показать, как установить tmux 2.0 (Что лучше, нет причин использовать 1.9 больше).

вот шаги по обновлению "пустой" ubuntu-версия 14.04 только (см. ниже для других ubuntu версии):

  1. sudo apt-get update
  2. sudo apt-get install -y python-software-properties software-properties-common
  3. sudo add-apt-repository -y ppa:pi-rho/dev
  4. sudo apt-get update
  5. sudo apt-get install -y tmux=2.0-1~ppa1~t
  6. теперь, если вы делаете tmux -V он должен показывать tmux 2.0 что является хорошей версией для плагинов tmux

я проверил вышеуказанные шаги на новой капле digitalocean.

в основном, это добавить Пи-Ро на/dev репозитория, обновление и последующая установка tmux из там.

если у вас есть другая версия ubuntu, вы можете установить другую версию tmux из того же РЕПО. Итак:

  • ubuntu 12.04 (точный Панголин) Шаг 5:sudo apt-get install -y tmux=1.9a-1~ppa1~p (устанавливает tmux 1.9, нет пакета для tmux 2.0 пока)
  • ubuntu 13.10 (дерзкая Саламандра) Шаг 5:sudo apt-get install -y tmux=1.9a-1~ppa1~s (устанавливает tmux 1.9, нет пакета для tmux 2.0 пока)
  • ubuntu 14.10 (утопический Единорог) Шаг 5:sudo apt-get install -y tmux=2.0-1~ppa1~u
  • ubuntu 15.04 (Яркая Вербена) Шаг 5:sudo apt-get install -y tmux=2.0-1~ppa1~v

Если вы не хотите добавлять PPA, вы можете просто построить его из источника. Это объясняется в README on GitHub tmux страницы:

чтобы построить tmux из выпускного тарбола, выполните:

$ ./configure && make
$ sudo make install

возможно, вам потребуется установить несколько дополнительных пакетов для его сборки. На Ubuntu мне нужно было установить эти пакеты, прежде чем он будет успешно строить:

exuberant-ctags
cmake
libevent-dev
libncurses5-dev

другой способ сделать #3 выше (особенно если вы используете корпоративный прокси, который может нарушить ppa).

sudo add-apt-repository -y http://ppa.launchpad.net/pi-rho/dev/ubuntu

Если вы используете такой инструмент, как Artifactory, чтобы действовать как прокси-сервер пакета кэширования

sudo add-apt-repository -y http://my.artifactory.site/ppa.launchpad.net/pi-rho/dev/ubuntu

или

sudo add-apt-repository -y http://my.domain/artifactory/ppa.launchpad.net/pi-rho/dev/ubuntu